
2024/05/13 14:51 1/12 Deleting holdings in OCLC's WorldCat

PINES Documentation - https://pines.georgialibraries.org/dokuwiki/

Deleting holdings in OCLC' WorldCat

While PINES staff will routinely batch updating (also known as setting or adding) holdings in OCLC’s
WorldCat, deleting holdings remains the responsibility of individual library systems. Deleting holdings
assists interlibrary loan staff so that they do not get ILL requests for titles no longer held by a system. It
is also part of GOLD compliance. It can, unfortunately, be a time consuming process.

With the exception of the Middle Georgia Regional Library System (which has one for the system and one
for the Genealogy department), all PINES libraries have one OCLC symbol. This means all holdings,
regardless of the number of branches in a system, are held under that one symbol on a bibliographic
record in OCLC’s WorldCat. Individual copies are also not indicated in WorldCat – it doesn’t matter if a
library has one or 100 copies of a title. You only need to delete holdings on the corresponding record in
OCLC if you have deleted your system’s last copy attached to a bibliographic/title record in the PINES
database. If just one copy is retained by your system, take no action in OCLC.

Determining last copy

You may already have a procedure in place identifying last copies that works perfectly fine with your
workflow. The ideas here are not prescriptive and are intended to be just suggestions. They may not
work for you or they may be a better option than what you are doing now.

If you are deleting a few items, determining last copy is simple – you can delete from holdings
maintenance and tell from there if any other copies are attached to your library system. If deleting older
titles and your library is one of those with multiple records from prePINES databases, you may need to do
a quick title search in PINES to be certain.

Once you have established a list of title records with your library’s holdings no longer attached, you can
then move to OCLC’s Connexion Client to delete holdings in OCLC. See section: Deleting holdings in
Connexion Client for further information.

Using Item Status (F5)

You can delete barcodes in Item Status and determine after deletion if the item was the last copy.

1. Set your default view to Holdings View.

2. Load barcodes into Item Status (F5). There are three ways to load items into Item Status:

Directly entering barcodes
Uploading a txt file of barcodes
Transferring items from a copy bucket to Item Status

3. Once your items are in Item Status, working in batches of 20 or less, delete the items and then pick
Show in Catalog from the Actions menu.

https://pines.georgialibraries.org/dokuwiki/doku.php?id=cat:deleting_holdings_in_oclc#deleting_holdings_in_connexion_client
https://pines.georgialibraries.org/dokuwiki/doku.php?id=cat:deleting_holdings_in_oclc#deleting_holdings_in_connexion_client
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4. Go to each tab and check in Holdings View for your library’s holdings. If there are additional copies in
your system, no further action is needed. If there are no additional items attached to your system, you
will need to build a file or list to assist in OCLC deletions. Again, you have several options:

You can add all records with no library holdings to a record bucket. This includes records
automatically deleted if you deleted the last copy attached to the bibliographic record. See
instructions in the section Creating files for Connexion Client Batch Processing to proceed from the
buckets.
You can copy the TCNs (Title Control Numbers) for OCLC records (those with the TCN prefix ocm or
ocn) to a txt or NotePad file. See section for batchprocessing files in the section Deleting
Holdings in Connnexion.

5. Then add records that are not OCLC records to a record bucket. See instructions for deleting holdings
from records with no OCLC based TCN.

Using MSExcel spreadsheets with Pivot Tables

1. Assign all items to be deleted the status Discard/Weed.

Using copy buckets, put all items to be deleted in a Copy Bucket or buckets, depending on
numbers (you can transfer the barcodes from Item Status (F5) into a copy bucket). Use Batch: Edit
Item attributes to change status to Discard/Weed. If branch staff add items to be deleted to a Copy
Bucket, they can share the bucket with you by giving you the bucket ID number.

2. Run report using the template Last copies, with count ID (clone) found in shared folder: elainehardy →
OCLC holdings maintenance reports as well as in the PINES Quick Reports interface → Items → OCLC
Holdings Maintenance: Last Copies.

3. Open the report in MSExcel.

Inserting a PivotTable in MSExcel

1. Delete any row that has a blank barcode, library, or status. (If you sort by barcode, library, then status,
it will clump all the blanks together. Then sort by column A [Title Proper or Title] when done.)

2. Highlight the data table (Ctrl + A). Then Insert → PivotTable.

When Create PivotTable pops up, click OK.

3. From the PivotTable Field List, click and drag:

TCN value → Row Labels
Name or Copy Status → Column Labels
Copy ID or Count → Values

Field list labels will depend on whether you ran the report in the traditional reports interface or in Quick
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Reports.

4. Put your cursor anywhere in the data table, then use Ctrl + A to highlight all and Copy.

Open a new sheet tab and Paste Values.

5. Delete any empty initial rows and the row Sum of Copy ID or Count, then Sort → Discard/Weed:
Smallest → Largest → Add level → Grand Total → Smallest to Largest.

6. Delete any rows that contain other statuses besides Discard/Weed (Unless you want to also use this
report to investigate other statuses such as lost or missing).

The remaining rows should have Discard/weed = 1, Grand Total = 1. These are the records with the
last copy for your system.

7. For OCLC based title control numbers, follow directions for creating a file to batch delete holdings in
the Connexion Client.

8. For non-OCLC based title control numbers, before you delete the items you will need to look at the
records to get sufficient information to locate a possible record in OCLC.

Delete discard/weed items in PINES.

After you have collected the information you need to delete holdings in OCLC, you can return to your
Discard/weed copy buckets and delete the items there or transfer them to Item Status to delete.

Creating files for Connexion Client Batch Processing

You can create text files of OCLC title control numbers or ISBNs to import into the Connexion Client for
batch processing. Files of OCLC title control numbers can be easily processed for holdings deletion.
Processing a file of ISBNs (for those records without OCLC based TCNs) requires more steps.

OCLC based title control numbers: ocm/ocn/on title control numbers

Connexion Client allows you to import a file of OCLC title control numbers and process delete holdings in
a batch. You first need to create a text file of the TCNs without the ocm, ocn, or on prefixes.

Creating a text file from a PINES/Evergreen report

1. Open in MSExcel the Last Copy report or other report that includes title control numbers for OCLC
deletes.

2. Delete unnecessary columns and headers leaving just the title control numbers.
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3. Sort so that non OCLC TCNs can be deleted. (You can create a separate file of these TCNs if you need
to investigate them further).

You can remove duplicated TCNs at this point.

4. If there are more than 2500 rows, you should break apart the file into smaller numbers. You can do
this by either cutting or pasting into a word doc or into different sheets in the spreadsheet. You will need
to save each sheet as a .txt file.

5. Remove all ocm, ocn, and on prefixes.

6. MSExcel may delete all initial zeros. If your column is not formatted for numbers you may see
barcodes in this format: 1.22E+08. Highlight the column and format the cell to read as numbers by right
clicking, choosing Format Cells, Numbers:

https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:remove_duplicates_excel.png
https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:find_replace.png
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7. Then save as a .txt file: Text (Tab delimited):

8. You are now ready to batch process the file(s) in the Connexion Client.

Creating a text file from a list

1. If you have created a list of OCLC TCNs in Notepad or MSWord, delete all ocm and ocn prefixes. It isn’t
necessary to delete the initial zeros. If it is A MSWord document, save as a Plain Text file.

Notepad files are text files.

2. You are now ready to batch process the file in the Connexion Client.

Creating a text file from a from a record bucket

1. In your bucket loaded with records for OCLC holdings deletion (either copy or record), use the column

https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:format_as_numbers.png
https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:saves_as_text_tab_delimited.png
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picker to display only the TCN.

2. Download the full csv (Save file as Plain Text):

3. Open the file you just saved in MSWord. Then remove “TCN”, all quotes and the ocm, ocn, and on
prefixes. Resave the file as a Plain Text File.

4. You are now ready to batch process file in the Connexion Client.

Non OCLC based title control numbers: PIN, etc.

If you have ISBNs for some of your nonOCLC records, you can do limited batch processing of them. Keep
in mind that you may retrieve more than one record from WorldCat when you process the file. Also keep
in mind that you may have multiple records in PINES with the same ISBN and that some of those records
may still have holdings attached and should not be deleted from OCLC. It may be better to search for
these records individually in OCLC from a list with more information so that you can be assured of
deleting holdings from the correct record. If the records do not have ISBNs, it is not practical to create a
file to batch search OCLC. You will need to do those one at a time in the Connexion Client.

Creating a text file from a PINES/Evergreen report

If you have a report that includes the ISBNs, create a text file as above of just the ISBNs. Once it is
created, you are ready to batch process in the Connexion Client.

https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:download_full_csv.png
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Creating a text file from a list

If you have a Notepad or MSWord file of a list of ISBNs, create a text file of the ISBNs as above. Once it is
created, you are ready to batch process in the Connexion Client.

Creating a text file from a record bucket

In your record or copy bucket, use the column picker to display ISBN only. Follow the directions above to
create a text file. Once it is created, you are ready to batch process in the Connexion Client.

Deleting holdings in Connexion Client

You can delete holdings in OCLC’s Connexion Client either singly or in a batch. Batch searching and
deleting is best used when you have the OCLC based title control numbers for the records. If you have
ISBNs, you can also batch search; but it is best to delete from the local save file so that you can be sure
you are deleting holdings from the correct record since multiple title records can be retrieved for an
ISBN.

The following instructions assume familiarity with OCLC’s Connexion Client. For more detailed
instructions for the client see Connexion client documentation.

Using Batch Holdings by OCLC Number in Connexion Client to delete holdings

These instructions are for files containing OCLC numbers only. If your file is ISBNs or other
search keys, the procedure differs.

Create a text file of OCLC numbers for the records for holdings deletion (ones where the last copy in your
system has been deleted in the PINES database). Remember:

Enter each OCLC number on a separate line.
In Batch Holdings by OCLC Number, OCLC TCNs can be entered with or without the prefix and with
or without preceding each with no:, *, or #.
OCLC’s recommended limit for files is 2,500 OCLC numbers at a time. (The text box containing the
OCLC numbers you enter or import has a limit of 32,767 characters). Work with numbers you are
comfortable with.

Setting up Connexion client

Make sure you have a default authorization/login set (use the OCLC login for the Z39.50 interface in
PINES Evergreen). If you do not have a default authorization set the batch process will fail. The error

http://www.oclc.org/support/services/connexion/documentation/client.en.html
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message will indicate you have an incorrect login.

You can setup a default login either at the login screen

Or under Tools → Options → Authorizations.

https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:pasted:20200806-103252.png
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You also will need several settings under Tools → Options → Batch:

Retain Batch search keys (retaining search keys allows you to troubleshoot if errors occur)
Too many matches
Not found or error

Record action
Check “Delete attached LHRs and Local Bib Data when deleting holdings”

Perform local actions in batch
Check Bibliographic Record Export

Display batch reports automatically. (Batch holdings by OCLC number defaults to automatically
open the report after action is completed; but, it is a good idea to set this for any other batch
processes you might do at another time)

You can set to have the report print automatically as well.

https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:pasted:20200806-103706.png
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Make sure you click on the Apply and then OK buttons to retain settings.

Settings will save and will apply to all subsequent batch actions.

Batch Holdings by OCLC Number

From Batch Select Holdings by OCLC Number:

You can enter OCLC TCNs

Individually,
Copy and paste them in the input well,
Import a text file of TCNs.

Click Browse to locate and import a text file of OCLC numbers.

https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:pasted:20200806-104824.png
https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:pasted:20200806-110610.png
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Don’t choose to delete your original import file in case correctable errors occur with the
batch process

However the numbers are entered, you can view, check, or delete numbers at this point.

Once you are ready to delete holdings, select Delete Holdings and click on OK:

You can cancel rather than process the file. Click Cancel : the window closes and the OCLC numbers are

https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:pasted:20200806-110935.png
https://pines.georgialibraries.org/dokuwiki/lib/exe/detail.php?id=cat%3Adeleting_holdings_in_oclc&media=cat:pasted:20200806-111132.png
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not retained in the interface.

The OCLC numbers are processed immediately when you click OK.

The client does not store the numbers.

Batch by OCLC Number Report

After the batch runs, the client automatically displays a report showing the record numbers, titles, and
actions completed or failed. It will print the report automatically if you have set it to do so. You can print
from here if you did not set up automatic printing.

Use the report to resolve any errors.

The most recent batch report for processing holdings by OCLC number is retained until you run another
batch of holdings by OCLC number. To view the most recent report, click Batch > View Reports >
Batch by OCLC Number Report.

The report displays:

Session ID
Report start time
Session duration
Lists of the records you entered in groups of failed or successful actions with totals for each group
For each record, displays:

OCLC control number
Title (if record found)
Record action
Result of action
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